Rubyエージェントのシステム要件

Rubyエージェントをインストールする前に、以下のシステム要件を満たす必要があります。

  • 分析対象となるデプロイ済のアプリケーションがあり、WebアプリケーションのテクノロジがContrastによってサポートされている。

  • アプリケーションを再起動できる。

  • WebサーバがContrastとネットワークで接続されている。

  • WebサーバがRubyGemsとネットワークで接続されているか、エージェントが手動でインストールされている。

  • サーバが以下の表に示す最小要件を満たしている。

    要件

    バージョン

    備考

    オペレーティングシステム

    • 64ビットLinux (推奨)

    • 64ビットOSX

    • 64ビットAlpine

    エージェントのバージョン3.0.0以降では、gemインストール手順でC拡張のコンパイルが必要になります。この処理は自動的に行われますが、ターゲット環境に以下をインストールしなければならない場合があります。

    • gccmakeautomakeautoconf (パッケージ名は異なる場合があります)。build-essentialのプラットフォームのバージョンをインストールできます。

    • システムヘッダ

    エージェントは、Rubyのアプリケーション層で実行する際にいくつかのCとの依存関係があるため、g libcまたはmusl libcベースのシステムでのコンパイルを許可するために--platform rubyフラグを付けてインストールしなければならない場合があります。

    Ruby gems

    • ougai:~>1.8 (1.8以降、2より前)

    • parser:~>2.6 (2.6以降、3より前)

    • protobuf:~>3.10 (3.10以降、4より前)

    • rack:~>2.0 (2.0以降、3より前)