Skip to main content

Pythonエージェントのシステム要件

警告

現在、Pythonエージェントは、M1チップを搭載したMacでの実行をサポートしていません。

Pythonエージェントをインストールする前に、以下のシステム要件を満たす必要があります。

  • 検査対象のアプリケーションがデプロイされており、そのWebアプリケーションのテクノロジはContrastのサポート対象であること。

  • アプリケーションは再起動可能であること。

  • WebサーバがContrastとネットワークで接続されていること。

  • WebサーバがPyPIとネットワークで接続されているか、エージェントが手動でインストールされていること。

  • サーバが以下の表に示す最小要件を満たしていること。

    要件

    バージョン

    備考

    オペレーティングシステム

    • 64ビットOS X

    • 64ビットLinux

    エージェントのバージョン2.3.0以降で、パッケージのインストール時にC拡張のコンパイルが必要になります。この処理は自動的に行われますが、ターゲット環境に特定のソフトウェアがインストールされている必要があります。

    • 必須:gccmakeautomakeautoconf。パッケージ名はプラットフォームによって異なる場合があります。お使いのプラットフォームのバージョンのbuild-essentialのインストールやシステムヘッダのインストールが必要な場合があります。Alpineでエージェントを実行する場合は、libtoolが必要です。

    Pythonパッケージ

    • protobuf:3.12以降

    • psutil:5.7以降

    • pip:6以降